Задать вопрос
13 июня, 09:33

Напишите программу, которая определяет, верно ли, что введённое число содержит ровно три одинаковые цифры, а все остальные встречаются только по одному разу (например, как в числе 77237) PascalABC

! решать при помощи while!

+2
Ответы (1)
  1. 13 июня, 12:56
    0
    Var

    A, B0, B1, B2, B3, B4, B5, B6, B7, B8, B9:integer;

    Begin

    WriteLn ('Введите число') ;

    ReadLn (A) ;

    While A>0 do

    Begin

    Case A mod 10 of

    0:B0:=B0+1;

    1:B1:=B1+1;

    2:B2:=B2+1;

    3:B3:=B3+1;

    4:B4:=B4+1;

    5:B5:=B5+1;

    6:B6:=B6+1;

    7:B7:=B7+1;

    8:B8:=B8+1;

    9:B9:=B9+1;

    End;

    A: = A div 10;

    End;

    if (B0 = 3) and (B1<2) and (B2<2) and (B3<2) and (B4<2) and (B5<2) and (B6<2) and (B7<2) and (B8<2) and (B9<2) then WriteLn ('Верно')

    else if (B1 = 3) and (B2<2) and (B3<2) and (B4<2) and (B5<2) and (B6<2) and (B7<2) and (B8<2) and (B9<2) and (B0<2) then WriteLn ('Верно')

    else if (B2 = 3) and (B3<2) and (B4<2) and (B5<2) and (B6<2) and (B7<2) and (B8<2) and (B9<2) and (B0<2) and (B1<2) then WriteLn ('Верно')

    else if (B3 = 3) and (B4<2) and (B5<2) and (B6<2) and (B7<2) and (B8<2) and (B9<2) and (B0<2) and (B1<2) and (B2<2) then WriteLn ('Верно')

    else if (B4 = 3) and (B5<2) and (B6<2) and (B7<2) and (B8<2) and (B9<2) and (B0<2) and (B1<2) and (B2<2) and (B3<2) then WriteLn ('Верно')

    else if (B5 = 3) and (B6<2) and (B7<2) and (B8<2) and (B9<2) and (B0<2) and (B1<2) and (B2<2) and (B3<2) and (B4<2) then WriteLn ('Верно')

    else if (B6 = 3) and (B7<2) and (B8<2) and (B9<2) and (B0<2) and (B1<2) and (B2<2) and (B3<2) and (B4<2) and (B5<2) then WriteLn ('Верно')

    else if (B7 = 3) and (B8<2) and (B9<2) and (B0<2) and (B1<2) and (B2<2) and (B3<2) and (B4<2) and (B5<2) and (B6<2) then WriteLn ('Верно')

    else if (B8 = 3) and (B9<2) and (B0<2) and (B1<2) and (B2<2) and (B3<2) and (B4<2) and (B5<2) and (B6<2) and (B7<2) then WriteLn ('Верно')

    else if (B9 = 3) and (B0<2) and (B1<2) and (B2<2) and (B3<2) and (B4<2) and (B5<2) and (B6<2) and (B7<2) and (B8<2) then WriteLn ('Верно')

    else WriteLn ('Не верно')

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая определяет, верно ли, что введённое число содержит ровно три одинаковые цифры, а все остальные встречаются ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
1) Напишите программу, которая определяет, верно ли, что введенное число состоит из одинаковых цифр (например, 222) 2) Напишите программу, которая определяет, верно ли, что введеное число содержит две одинаковые цифры, стоящие рядом (например, 221)
Ответы (1)
Программа паскаль Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Напишите программу которая определяет верно ли что введенное число содержит по крайней мере две одинаковые цифры возможно не стоящие рядом как например 212
Ответы (1)
Напишите программу которая определяет Верно ли что введенное число содержит по крайней мере две одинаковые цифры Возможно не стоящие рядом Паскаль ABC net
Ответы (1)