Задать вопрос
4 сентября, 05:42

Написать программу на языке Паскаль, реализующую следующую задачу: Продаются товары двух видов. Запросить с клавиатуры для каждого товара цену, количество в начале рабочего дня и количество проданного товара (и одного и другого) за день. Вывести выручку от продажи двух товаров за день.

+4
Ответы (1)
  1. 4 сентября, 09:06
    0
    Запрашивается цены товаров и их количество в начале рабочего дня.

    Запрашивается количество проданного товара.

    Выводится ответ.

    Возможно, надо было запросить не кол-во проданного товара, а кол-во оставшегося товара, но я составил программу по условию. (если нужна будет другая, то отредактирую)

    program tovar;

    var t1, t2, p1, p2:integer;

    c1, c2, s:real;

    Begin

    WriteLn ('Сколько товаров первого вида было в начале рабочего дня?') ;

    ReadLn (t1) ;

    WriteLn ('Цена товаров первого вида?') ;

    ReadLn (c1) ;

    WriteLn ('Сколько товаров второго вида было в начале рабочего дня?') ;

    ReadLn (t2) ;

    WriteLn ('Цена товаров второго вида?') ;

    ReadLn (c2) ;

    WriteLn ('сколько товаров перового вида было продано за день?') ;

    ReadLn (p1) ;

    WriteLn ('сколько товаров второго вида было продано за день?') ;

    ReadLn (p2) ;

    s:=p1*c1+p2*c2;

    WriteLn ('Выручка за день ', s) ;

    end.

    / / / Возник вопрос. Зачем спрашивать, сколько товаров было в начале рабочего дня, если эти данные не используются, вот я и решил составить программу, которая, возможно, требовалась

    program tovar;

    var t1, t2, p1, p2:integer;

    c1, c2, s:real;

    Begin

    WriteLn ('Сколько товаров первого вида было в начале рабочего дня?') ;

    ReadLn (t1) ;

    WriteLn ('Цена товаров первого вида?') ;

    ReadLn (c1) ;

    WriteLn ('Сколько товаров второго вида было в начале рабочего дня?') ;

    ReadLn (t2) ;

    WriteLn ('Цена товаров второго вида?') ;

    ReadLn (c2) ;

    WriteLn ('сколько товаров перового вида осталось?') ;

    ReadLn (p1) ;

    WriteLn ('сколько товаров второго вида осталось?') ;

    ReadLn (p2) ;

    s: = (t1-p1) * c1 + (t2-p2) * c2;

    if (t1-p1<0) or (t2-p2<0) then WriteLn ('Внимание! Кол-во оставшихся товаров, больше чем кол-во товаров в начале рабочего дня. Проверьте правильность данных.') ;

    WriteLn ('Выручка за день ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на языке Паскаль, реализующую следующую задачу: Продаются товары двух видов. Запросить с клавиатуры для каждого товара ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль Определить наибольшую выручку от продажи трех видов товаров, если известны: цена товара; количество проданных товаров каждого вида. Составить код программы
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Дан массив А, в котором хранится стоимость N товаров. Весь товар подешевел на р%. Сформировать массив В, в котором хранится новая стоимость товаров. Вывести на экран в столбец номер товара, старая цена и новая цена.
Ответы (1)
Написать программу на языке Паскаль для решения следующей задачи: запросить через цикл ввод 14 чисел и среди них найти наибольшее (вывести его на экран)
Ответы (1)
Напишите программу на алгоритмическом языке. Магазин продает В машин по цене А руб. за каждую. Найдите общую выручку от продажи машин (все необходимые значения введите с клавиатуры) (Для Кумира)
Ответы (1)