Задать вопрос
7 ноября, 12:34

Написать программу, которая определяет в одномерном массиве, заполненном случайным образом, количество элементов, значения которых меньше числа, введенного с клавиатуры. Если есть, то вывести эти элементы

+2
Ответы (1)
  1. 7 ноября, 14:08
    0
    Program n1;

    const n=17;

    var a: array[1 ... n] of integer;

    i, c, k: integer;

    begin

    randomize;

    write ('введите число: ') ;

    readln (c) ;

    writeln ('массив: ') ;

    for i:=1 to n do

    begin

    a[i]:=random (50) ;

    write (a[i],' ') ;

    end;

    writeln;

    writeln ('эл. которые меньше ', c) ;

    for i:=1 to n do if a[i]
    begin

    k:=k+1;

    write (a[i],' ') ;

    end;

    writeln;

    writeln ('количество: ', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая определяет в одномерном массиве, заполненном случайным образом, количество элементов, значения которых меньше ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.
Ответы (2)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
Дан массив, состоящий из целых чисел. Напишите программу, которая определяет, есть ли в массиве пара соседних элементов с одинаковыми знаками. Входные данные Сначала задано число N - количество элементов в массиве (1N10000).
Ответы (1)
Помогите написать программу! Дан целочисленный массив M из 15 элементов. Элементы массива могут принимать целые значения от - 500 до 500 и вводятся с клавиатуры. Найти и вывести: 1. Сумму квадратов отрицательных элементов.
Ответы (1)