Задать вопрос
1 апреля, 07:38

Не особо шарю в паскале. Нужна помощь. Нужно написать программу для определения какой четверти принадлежит точка. Мне не нужно решение из интернета, без комментариев и прочего. По возможности с объяснением, а то дальше не вытяну информатику

+2
Ответы (1)
  1. 1 апреля, 11:05
    0
    Var x, y:integer;

    begin

    writeln ('Программа определения местонахождения точки') ;

    writeln ('Введите координаты точки') ;

    readln (x, y) ; / / вводим координаты точки

    if (x>=0) and (y>=0) then writeln ('1 четверть') ; / / точка принадлежит 1 ч. если обе координаты положительны (это из геометрии)

    if (x=0) then writeln ('2 четверть') ; / / точка принадлежит 2 ч. если х<0, а y неотрицателен (это из геометрии)

    if (x<0) and (y<0) then writeln ('3 четверть') ; / / точка принадлежит 3 ч. если обе координаты отрицательны (это из геометрии)

    if (x>=0) and (y<0) then writeln ('4 четверть') ; / / точка принадлежит 4 ч. если х неотрицателен, а y<0 (это из геометрии)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Не особо шарю в паскале. Нужна помощь. Нужно написать программу для определения какой четверти принадлежит точка. Мне не нужно решение из ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу, определяющую, какой четверти декартовой системы координат принадлежит точка (x, y). На входе - координаты точки, на выходе - номер четверти. Выполнять в паскале Если точно не знаете, то не пишите
Ответы (1)
Даны целочисленные координаты X и Y. Написать программу, которая выводит на экран сообщение "Принадлежит" или "Не принадлежит" эта точка 1-ой четверти координатной плоскости. Точки на осях координат считаются принадлежащими к данной четверти.
Ответы (1)
Напишите программу, которая подсчитает, сколько существует двузначных положительных чисел сумма цифр которых не превышает 15 (Паскаль). Нужно написать программу используя div и mod, без string и прочего!
Ответы (1)
доброго времени суток.) кто-нибудь может помочь? ибо я совсем не вывожу информатику. 1. Написать программу, которая вводит массив из N целых чисел и выводит на экран элементы с чётными номерами.
Ответы (1)
Помогите решить информатику составить "программу Паскаль" 1. Определить принадлежит ли точка А (х) отрезку [-5; 7]
Ответы (1)