Задать вопрос
24 августа, 01:33

Написать программу на языке Паскаль: Гражданин 1 марта открыл счет в банке, вложив 1000 руб. Через каждый месяц размер вклада увеличивается на 2% от имеющейся суммы. Опре-делить: а) за какой месяц величина ежемесячного увеличения вклада превысит 30 руб.; б) через сколько месяцев размер вклада превысит 1200 руб.

+2
Ответы (1)
  1. 24 августа, 02:20
    0
    Var s, ds:real; k1, k2:integer;

    begin

    //a

    s:=1000; ds:=0; k1:=0;

    while ds<=30 do

    begin

    ds:=s*0.02;

    s:=s+ds;

    k1:=k1+1;

    end;

    writeln ('k1 = ', k1) ;

    //б

    s:=1000; ds:=0; k2:=0;

    while s<=1200 do

    begin

    s:=1.02*s;

    k2:=k2+1;

    end;

    writeln ('k2 = ', k2) ;

    end.

    Результат:

    k1 = 22

    k2 = 10
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на языке Паскаль: Гражданин 1 марта открыл счет в банке, вложив 1000 руб. Через каждый месяц размер вклада увеличивается ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Гражданин 1 марта открыл счет в банке, вложив 1000 руб. Через каждый месяц размер вклада увеличивается на 2% от имеющейся суммы. Определить: за какой месяц величина ежемесячного увеличения вклада превысит 30 руб.
Ответы (1)
Помогите напишите задачу и ее решение в паскале. Составить программу для решения следующей задачи: Гражданин 1 марта открыл счет в банке, вложив 1000 руб. Через каждый месяц размер вклада увеличивается на 2% от имеющейся суммы.
Ответы (1)
Гражданин 1 января открыл счёт в банке, вложив 100 000 р. Каждый месяц размер вклада увеличивается на 3% от имеющийся суммы. Составьте программу для определения суммы вклада через 1, 2, ..., 12 месяцев.
Ответы (1)
C# 25 б Начальный вклад в банке равен 100 000 тг. Через каждый месяц размер вклада увеличивается на P процентов от имеющейся суммы. По данному P определить, через сколько месяцев размер вклада превысит 1 500 000 тг.
Ответы (1)
Гражданин открыл счёт в банке 1 марта на 1000 рублей. Каждый месяц сумма увеличивалась на 2%. Через сколько месяцев размер вклада превысит 1200 рублей? Составить программу на Pascal и блок схему!
Ответы (1)