Задать вопрос
24 декабря, 02:29

Гражданин 1 марта открыл счет в банке, вложив 1000 руб. Через каждый месяц размер вклада увеличивается на 2% от имеющейся суммы. Определить: за какой месяц величина ежемесячного увеличения вклада превысит 30 руб.; через сколько месяцев размер вклада превысит 1200 руб. (Pascal ABC)

+4
Ответы (1)
  1. 24 декабря, 06:09
    0
    Const

    s0=100000; { первоначальная сумма в копейках }

    p=0.02; { величина, равная 1/100 от ежемесячного процента }

    var

    s, sp:longint;

    mes:integer;

    begin

    { все расчеты ведем в копейках }

    mes:=0; s:=s0;

    while sp<=30*100 do

    begin mes:=mes+1; sp:=Round (s*p) ; s:=s+sp end;

    Writeln ('Месяц ', mes,', сумма процента ', sp/100:0:2,' > 30') ;

    mes:=0; s:=s0;

    while s<=1200*100 do begin mes:=mes+1; s:=s+Round (s*p) end;

    Writeln ('Месяц ', mes,', сумма вклада ', s/100:0:2,

    ' > 1200') ;

    end.

    Результат выполнения программы:

    Месяц 22, сумма процента 30.31 > 30

    Месяц 10, сумма вклада 1218.98 > 1200
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Гражданин 1 марта открыл счет в банке, вложив 1000 руб. Через каждый месяц размер вклада увеличивается на 2% от имеющейся суммы. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу на языке Паскаль: Гражданин 1 марта открыл счет в банке, вложив 1000 руб. Через каждый месяц размер вклада увеличивается на 2% от имеющейся суммы.
Ответы (1)
Помогите напишите задачу и ее решение в паскале. Составить программу для решения следующей задачи: Гражданин 1 марта открыл счет в банке, вложив 1000 руб. Через каждый месяц размер вклада увеличивается на 2% от имеющейся суммы.
Ответы (1)
Гражданин 1 января открыл счёт в банке, вложив 100 000 р. Каждый месяц размер вклада увеличивается на 3% от имеющийся суммы. Составьте программу для определения суммы вклада через 1, 2, ..., 12 месяцев.
Ответы (1)
C# 25 б Начальный вклад в банке равен 100 000 тг. Через каждый месяц размер вклада увеличивается на P процентов от имеющейся суммы. По данному P определить, через сколько месяцев размер вклада превысит 1 500 000 тг.
Ответы (1)
Гражданин открыл счёт в банке 1 марта на 1000 рублей. Каждый месяц сумма увеличивалась на 2%. Через сколько месяцев размер вклада превысит 1200 рублей? Составить программу на Pascal и блок схему!
Ответы (1)