Задать вопрос
13 июня, 16:24

Помогите написать программу в Паскале.

Дано трёхзначное число N. Определить, какая из его цифр больше - первая или вторая. Если цифры одинаковы, то выдать об этом сообщение.

+4
Ответы (1)
  1. 13 июня, 16:49
    0
    Var

    a, b:integer;

    Begin

    Write ('Введите трёхзначное число: ') ;

    ReadLn (a) ;

    b: = (a div 10) mod 10;

    a:=a div 100;

    if a > b then Write ('Первая цифра больше')

    else if a < b then Write ('Вторая цифра больше')

    else Write ('Первые две цифры равны')

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу в Паскале. Дано трёхзначное число N. Определить, какая из его цифр больше - первая или вторая. Если цифры ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Дано трехзначное целое число. Найти сумму его цифр и выдать это число в "перевернутом" виде (было 123, выдать 321) Примечание. n1 - 1-я цифра исходного числа, n2 - вторая, n3 - третья (решение задачи в паскале)
Ответы (1)
Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число. 3) Дано трехзначное число.
Ответы (1)
1. Дано трехзначное число. Найти число единиц в нем число десятков в нем сумму его цифр произведение его цифр 2. Дано трехзначное число. Найти число. Найти число, полученное при прочтении его цифр справа налево
Ответы (1)
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)