Задать вопрос
5 декабря, 05:54

2. Укажите наибольшее и наименьшее из таких чисел, при вводе которых алгоритм печатает сначала 3, а потом 7.

var x, a, b : integer;

begin

readln (x) ;

a : = 0; b : = 1;

while x > 0 do begin

a : = a + 1;

b : = b + (x mod 6) ;

x : = x div 6;

end;

writeln (a) ; write (b) ;

end.

+5
Ответы (1)
  1. 5 декабря, 07:01
    0
    Немного изменив ваш код я получил вот это:

    var x, a, b : integer;

    begin

    for var i:=0 to MaxInt do

    begin

    a : = 0; b : = 1;

    x:=i;

    while x > 0 do

    begin

    a : = a + 1;

    b : = b + (x mod 6) ;

    x : = x div 6;

    end;

    If (a=3) and (b=7) then Println (a, b, i) ;

    end;

    end.

    Результат:

    3 7 41

    3 7 46

    3 7 51

    3 7 56

    3 7 61

    3 7 66

    3 7 76

    3 7 81

    3 7 86

    3 7 91

    3 7 96

    3 7 111

    3 7 116

    3 7 121

    3 7 126

    3 7 146

    3 7 151

    3 7 156

    3 7 181

    3 7 186

    Судя с результата, ответ: Минимальное - 41, Максимальное - 186
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «2. Укажите наибольшее и наименьшее из таких чисел, при вводе которых алгоритм печатает сначала 3, а потом 7. var x, a, b : integer; begin ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Определить значение выражения: 1) 10 div 15 2) 10 div 2 3) 10 mod 2 4) 10 mod 17 5) 123 mod 10 6) 123 div 10 7) 1 div 2 8) 123 mod 1000 9) 100 mod 27 div 3 10) 100 div 5 mod 3 11) 98725 div 1000 mod 10 12) 100 mod 5 div 3
Ответы (1)
Сделать так чтобы Writeln был заменен другим словом и повторялься не больше двух раз program choise; var N_M:integer; writeln (' введи номер месяца ') ; readln (N_M) ; case N_M of 1:writeln (' январь ') ; 2:writeln (' февраль ') ;
Ответы (1)
Тест: Операторы целочисленной арифметики div и mod 1. Вычислите: 25 div 11 2.27 3 2 2. Вычислите: 64 div 9 1 7 6 3. Вычислите: (35 div 2) div 5 2 17 3 4. Вычислите: (78 div 5) mod 10 5 15 10 5. Вычислите: (25 mod 11) + (18 mod 7) 3 7 4 6.
Ответы (1)
Объясните строчку (c:=10*c+a mod 10; a : = a div 10;) program pr36; function qwer (var a, b: integer) : integer; var c: integer; begin c:=0; while a > 0 do begin c:=10*c+a mod 10; a : = a div 10; end; qwer: = c; end; var a, b: integer;
Ответы (1)
Умоляю, помогите ... Ниже на двух языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наибольшее из таких четырёхзначных чисел x, при вводе которых алгоритм печатает сначала 7, а потом 29.
Ответы (1)