Задать вопрос
26 августа, 20:25

Помогите решить ... (програмирование)

Дано натуральное четырехзначное число. Найти произведение его второй и четвёртой цифры. (Pascal ABC)

+3
Ответы (1)
  1. 26 августа, 21:38
    0
    Если считать цифры справа налево (в числе 1234, цифра 4 - первая) :

    Var

    A:integer;

    Begin

    WriteLn ('Введите четырёхзначное число') ;

    ReadLn (A) ;

    WriteLn (((A div 10) mod 10) * (A div 1000)) ;

    End.

    Если считать слева направо (в числе 1234, цифра 1 - первая) :

    Var

    A:integer;

    Begin

    WriteLn ('Введите четырёхзначное число') ;

    ReadLn (A) ;

    WriteLn (((A div 100) mod 10) * (A mod 10)) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить ... (програмирование) Дано натуральное четырехзначное число. Найти произведение его второй и четвёртой цифры. (Pascal ABC) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc 2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)