Задать вопрос
1 января, 06:01

Составить программу в паскале, которая в массиве из десяти целых чисел считает среднее арифметическое отрицательных.

+5
Ответы (1)
  1. 1 января, 07:53
    0
    Const n=10;

    var a:array[1 ... n] of integer;

    i, s, k:integer;

    begin

    Randomize;

    writeln ('Массив A:') ;

    for i:=1 to n do

    begin

    a[i]:=random (51) - 25;

    write (a[i]:4) ;

    end;

    writeln;

    s:=0; k:=0;

    for i:=1 to n do

    if a[i]<0 then begin s:=s+a[i]; k:=k+1; end;

    writeln ('s = ', s,' k = ', k) ;

    if k>0

    then writeln ('Среднее арифметическое отрицательных = ', s/k)

    else writeln ('Отрицательных нет') ;

    end.

    Пример:

    Массив A:

    -11 11 13 9 - 11 - 2 18 - 18 3 - 14

    s = - 56 k = 5

    Среднее арифметическое отрицательных = - 11.2
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу в паскале, которая в массиве из десяти целых чисел считает среднее арифметическое отрицательных. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
2. В массиве Z[1 ... N] определить сумму нечетных чисел от последнего нулевого значения до Z[N] и среднее арифметическое четных чисел, находящихся в массиве до последнего нуля. Если нулей в массиве нет, то рассортировать все числа по убыванию.
Ответы (1)
Помогите написать программу в паскале! Написать программу в паскале: В одномерном массиве из 10 целых чисел вычислить сумму четных чисел ...
Ответы (1)
Ответьте в кумире или Паскале 1. Найти среднее арифметическое значений всех элементов массива, состоящего их случайных положительных чисел. 2. В массиве из 15-ти целых случайных чисел из диапазона [-30; 70] найти минимальный положительный элемент. 3.
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (2)