Задать вопрос
1 января, 09:32

Оператор ветвления

Что будет если выведено на экран.

Begin

a:=120

If a <120 then n:a+50 else n:a-10;

Writeln (n)

End

n=?

+3
Ответы (1)
  1. 1 января, 10:43
    0
    A< 120? (120<120? Нет)

    Идем по ветке else

    n: = a - 10 (120-10=110)

    Ответ: 110
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Оператор ветвления Что будет если выведено на экран. Begin a:=120 If a ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Соотнесите названия операторов, служебных слов, функций и их написание на языке Paskal: 1. Оператор ввода данных a) Begin, End 2. Условный оператор в неполной форме b) Sqrt (X) 3. Оператор цикла с предусловием c) N div M 4.
Ответы (1)
3. Чему будет равно значение целой переменной a после выполнения этого фрагмента программы? a:=2; for i:=0 to 2 do begin a:=a+i; end; Ответ: введите число 4.
Ответы (2)
Дан оператор i f a>5 then s:=s+1 else m:=m+2. Он является: a. Комбинацией операций ветвления b. Комбинацией операторов присваивания и ветвления c. Условным оператором d. Представлением условия e. Блочной структурой условия
Ответы (1)
1. В языке PHP создайте генератор случайного числа от 1 до 10. Выведите результат выполнения на экран любым способом. 2. Если полученное случайное число четное, выведите на экран слово "четное", иначе выведите на экран слово "нечетное". 3.
Ответы (1)
Определите что будет выведено на экран после выполнения следующего алгоритма: Var s:integer; k:real; Begin S:=25; If s mod 2 0 then Begin S:=s-1; K:=s/2 End Else k:=s; Writeln (k) End
Ответы (1)