Задать вопрос
12 января, 04:32

В паскале. Изменить программу так, что бы она находила: 1) сумму четырёх чисел

2) произведения чисел

3) квадрат каждого числа

+3
Ответы (1)
  1. 12 января, 05:33
    0
    Program SumProizDrob;

    Uses crt;

    var n:integer;

    c, s, pr, dr:real;

    begin

    clrscr;

    write ('Input Numbers:') ;

    n:=1; s:=0; pr:=1; dr:=0;

    repeat

    readln (c) ;

    dr:=frac (c) ;

    writeln ('drobnaya chast:', dr:4:4) ;

    n:=n+1;

    if (c>9) and (c<51) then

    s:=s+c;

    if (c<22) then

    pr:=c*pr;

    until (c=1000) ;

    writeln;

    writeln ('Summa = ', s:4:4) ;

    writeln ('Proizved=', pr:4:4) ;

    readkey;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В паскале. Изменить программу так, что бы она находила: 1) сумму четырёх чисел 2) произведения чисел 3) квадрат каждого числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Нужно в паскале написать программу с одномерным массивом из десяти элементов, чтоб она находила количество чётных, нечётных и среднее арифметическое. Это всё в одной программе.
Ответы (1)
Помогите написать программу в паскале! Написать программу в паскале: В одномерном массиве из 10 целых чисел вычислить сумму четных чисел ...
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Помогите написать программу на Паскале. Напишите программу, которая в последовательности целых чисел вычисляет сумму всех чисел, которые кратны 6 или 11.
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)