Задать вопрос
25 июня, 23:26

Нужно в паскале написать программу с одномерным массивом из десяти элементов, чтоб она находила количество чётных, нечётных и среднее арифметическое. Это всё в одной программе.

+1
Ответы (1)
  1. 26 июня, 01:54
    0
    var a:array [1 ... 10] of integer;

    i, k1, k2, s1, s2:integer;

    begin

    for i: = 1 to 10 do

    a[i]: = Random (100) ;

    writeln (a) ;

    for i:=1 to 10 do

    begin

    if a[i] mod 2 = 0 then

    begin

    k1:=k1+1;

    s1:=s1+a[i]

    end

    else

    begin

    k2:=k2+1;

    s2:=s2+a[i]

    end

    end;

    writeln ('Количество чётных элементов: ', k1) ;

    writeln ('Количество не чётных элементов: ', k2) ;

    writeln ('Cреднее арифметическое чётных элементов: ', s1/k1) ;

    writeln ('Cреднее арифметическое не чётных элементов: ', s2/k2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужно в паскале написать программу с одномерным массивом из десяти элементов, чтоб она находила количество чётных, нечётных и среднее ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите решить задачи в паскале. 1) найти сумму положительных элементов массива. 2) найти сумму четных элементов массива. 3) найти сумму всех четных элементов массива, стоящих на четных местах.
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
Имеется целочисленный массив состоящий из N элементов (N - чётное) а) Найти сумму первых N/2 элементов. б) Найти сумму элементов стоящих на чётных позициях. в) Найти произведение элементов стоящих на нечётных позициях.
Ответы (1)
Написать программу которая минимальное значение четных и не четных в заданном диапазоне и сумму и среднее ариф. Всех и четных и нечетных. python3 через цикл while
Ответы (1)