Задать вопрос
15 марта, 14:42

Вычислите сумму квадратов вводимых чисел, Числа вводятся пока не будет нажат 0

работа на паскале

+5
Ответы (2)
  1. 15 марта, 15:44
    0
    Var

    A, S:real;

    Begin

    Repeat

    Read (A) ;

    S:=S+A*A;

    Until A = 0;

    WriteLn ('S = ', S) ;

    End.
  2. 15 марта, 16:00
    0
    Uses crt;

    var a, k: Integer;

    begin

    while a 0 do

    begin

    readln (a) ;

    if a 0 then inc (k, sqr (a)) ;

    end;

    writeln (k) ;

    end;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислите сумму квадратов вводимых чисел, Числа вводятся пока не будет нажат 0 работа на паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
1. Построить и записать в виде программы алгоритм вычисления суммы квадратов десяти произвольных чисел, вводимых с клавиатуры в процессе выполнения программы. 2. Вводятся 15 чисел. Определить, сколько среди целых чисел. 3.
Ответы (1)
помогите решить три номера! 1. Вычислите сумму данных 100 натуральных чисел. Вводятся 100 чисел, сумму которых необходимо посчитать. 2. Вводится число N, а затем N чисел. Подсчитайте, сколько среди данных N чисел нулей. 3.
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
В одну и ту же числовую переменную последовательно вводятся целые числа. Количесвто вводимых чисел заранее известно (0 - конец ввода). Определить количество чисел не кратных 5.
Ответы (1)