Задать вопрос
4 февраля, 20:44

1. С клавиатуры вводят слово и символ. Составьте программу, которая определяет позицию данного символа.

+3
Ответы (1)
  1. 4 февраля, 23:18
    0
    Var c: Char;

    s: String;

    i, k, p: Integer;

    Begin

    ReadLn (c) ; {Чтение заданного символа}

    ReadLn (s) ; {Чтение заданного слова}

    p: = Pos (c, s) ; {Определяем позицию символа}

    If (p=0) Then {Функция вернёт 0, если символ не будет найден}

    WriteLn ('Такого символа в слове нет.')

    Else {Если символ есть, то ... }

    Begin

    WriteLn ('Указанный символ расположен на позиции: ', p) ;

    k: = 0; {k хранит количество вхождений}

    p: = Length (s) ; {p хранит длину строки (слова) }

    For i:=1 To p Do {Пробегаем по всем символам слова}

    If (s[i]=c) Then inc (k) ; {Если символ совпадает, увеличиваем на 1 переменную k}

    WriteLn ('Количество вхождений данного символа: ', k) ;

    End;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. С клавиатуры вводят слово и символ. Составьте программу, которая определяет позицию данного символа. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С клавиатуры вводят слово и символ. Составьте программу, которая: а) проверяет, есть ли в этом слове данный символ; б) определяет позицию заданного символа; в) подсчитывает колличество вхождений заданного символа.
Ответы (1)
С клавиатуры вводят слово и символ. составить программу, которая: а) проверяет есть ли в этом слове заданный символ б) определяет позицию заданного символа в) подсчитывает количество вхождений заданного символа.
Ответы (1)
помогите решить задачю по информатике С клавиатуры последовательно вводят целые числа и высчитывается их сумма если с клавиатуры вводят 0, то больше числа не вводят. Найти сумму всех введеных чисел.
Ответы (1)
Помогите составить программу в Pascal ABC Составить программу, которая определяет: a) символ по его коду, введенному с клавиатуры; b) символ для кода 100; c) код для символа ' ' (пробел).
Ответы (1)
Помогите написать программу по инф-ке. С клавиатуры вводят символ. Составьте программу, которая выводит два следующих символа.
Ответы (1)