Задать вопрос
4 февраля, 19:47

В одну и ту же числовую переменную последовательно вводятся целые числа. Количесвто вводимых чисел заранее известно (0 - конец ввода). Определить количество чисел не кратных 5.

+2
Ответы (1)
  1. 4 февраля, 23:31
    0
    На паскале:

    Var x, k:integer;

    Begin

    k:=0;

    Repeat

    Readln (x) ;

    If (x mod 5 = 0) and (x0) then inc (k) ;

    Until x=0;

    Writeln (k) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В одну и ту же числовую переменную последовательно вводятся целые числа. Количесвто вводимых чисел заранее известно (0 - конец ввода). ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Последовательно вводятся целые положительные числа, пока не будет введено отрицательное число. Определить разность между суммой чисел кратных семи и количеством четных чисел.
Ответы (1)
1. Переключение клавиатуры с режима ввода латинских букв на режим ввода русских букв и обратно? 2. переключение клавиатуры с режима ввода строчных букв на режим ввода прописных букв и обратно? 3.
Ответы (1)
С клавиатуры вводятся целые числа. Окончание ввода - число ноль. Ноль используется только для указания окончания ввода и в остальных расчётах не участвует. Подсчитать среднее арифметическое тех отрицательных чисел, которые оканчиваются на цифру "5".
Ответы (1)
Вводятся целые числа, окончание ввода цифра 0. Найти сумму отрицательных нечетных чисел. Найти произведения положительных чисел кратных 3. Предусмотреть, если таких чисел не было - вывести информационное сообщение. Задача Паскаль
Ответы (1)