Задать вопрос
9 мая, 20:30

Вводятся целые числа, окончание ввода цифра 0. Найти сумму отрицательных нечетных чисел. Найти произведения положительных чисел кратных 3. Предусмотреть, если таких чисел не было - вывести информационное сообщение. Задача Паскаль

+1
Ответы (1)
  1. 9 мая, 22:01
    0
    Var k, sum, summ: Integer;

    begin

    summ:=1;

    repeat

    writeln ('Введите число') ;

    readln (k) ;

    if (k mod 20) and (k<0) then sum:=sum+k;

    if (k>0) and (k mod 3=0) then summ:=summ*k;

    until k=0;

    if (sum=null) and (summ=1) then writeln ('Нет таких чисел') else

    begin

    writeln ('Сумма: ', sum) ;

    writeln ('Произведение: ', summ) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вводятся целые числа, окончание ввода цифра 0. Найти сумму отрицательных нечетных чисел. Найти произведения положительных чисел кратных 3. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
С клавиатуры вводятся целые числа. Окончание ввода - число ноль. Ноль используется только для указания окончания ввода и в остальных расчётах не участвует. Подсчитать среднее арифметическое тех отрицательных чисел, которые оканчиваются на цифру "5".
Ответы (1)
Написать программу для паскаль. С клавиатуры вводятся целые числа. Признаком конца ввода является 0. Изменить знак отрицательных чисел на противоположный. Результаты вывести на экран.
Ответы (2)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)