Задать вопрос
3 октября, 16:07

Написать программу для паскаль. С клавиатуры вводятся целые числа. Признаком конца ввода является 0. Изменить знак отрицательных чисел на противоположный. Результаты вывести на экран.

+2
Ответы (2)
  1. 3 октября, 17:37
    0
    Var n: integer;

    s: string;

    begin

    writeln ('Вводите числа') ;

    repeat

    readln (n) ;

    s: = s + IntToStr (abs (n)) + ' '

    until n = 0;

    writeln (s) ;

    end.
  2. 3 октября, 19:48
    0
    Предложу решение, основанное на том, что понял из текста)

    var a: integer;

    begin

    writeln ('Вводите числа') ;

    a:=1;

    while a0 do begin

    readln (a) ;

    if a<0 then writeln ('Противоположное число ', abs (a)) ;

    end;

    readln

    end.

    Можно их в массив записывать, если нужно вывести красиво.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу для паскаль. С клавиатуры вводятся целые числа. Признаком конца ввода является 0. Изменить знак отрицательных чисел на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С клавиатуры вводятся целые числа. Признаком конца ввода чисел является 0. изменить знак отрицательных чисел на положительный. Результаты вывести на экран.
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1. Переключение клавиатуры с режима ввода латинских букв на режим ввода русских букв и обратно? 2. переключение клавиатуры с режима ввода строчных букв на режим ввода прописных букв и обратно? 3.
Ответы (1)
1. Прочитать с клавиатуры число n, затем прочитать n чисел и вывести на экран сумму тех из них, которые делятся на 3. 2. Прочитать с клавиатуры число n и вывести на экран сумму его четных цифр 3.
Ответы (1)