Задать вопрос
15 октября, 21:56

С клавиатуры вводятся целые числа. Признаком конца ввода чисел является 0. изменить знак отрицательных чисел на положительный. Результаты вывести на экран.

+3
Ответы (1)
  1. 16 октября, 01:16
    0
    uses

    System. Collections. Generic;

    var

    a: List : = new List () ; / / Объявляем и создаём динамический массив

    i: integer;

    begin

    repeat

    readln (i) ;

    if (i = 0) then

    break

    else

    a. Add (i) ;

    until (False) ; / / Прекращаем цикл, когда рак (break) в цикле свиснет (False можно заменить на "2 + 2 = 5"

    writeln (#13) ; / / Вставляем 2 пустые строки

    foreach i in a do / / Выводим исходный массив

    write (i, ' ') ;

    writeln () ;

    foreach i in a do / / Выводим конечные числа, нет задачи массив изменять

    write (abs (i), ' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры вводятся целые числа. Признаком конца ввода чисел является 0. изменить знак отрицательных чисел на положительный. Результаты ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу для паскаль. С клавиатуры вводятся целые числа. Признаком конца ввода является 0. Изменить знак отрицательных чисел на противоположный. Результаты вывести на экран.
Ответы (2)
1. Переключение клавиатуры с режима ввода латинских букв на режим ввода русских букв и обратно? 2. переключение клавиатуры с режима ввода строчных букв на режим ввода прописных букв и обратно? 3.
Ответы (1)
1. Прочитать с клавиатуры число n, затем прочитать n чисел и вывести на экран сумму тех из них, которые делятся на 3. 2. Прочитать с клавиатуры число n и вывести на экран сумму его четных цифр 3.
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)