Задать вопрос
31 августа, 23:44

Ребят подскажите по информатике S=|x-7|/7+|x-8|/7+|x-9|/9 + ... + |x-n|/n Вычислить сумму циклом с постусловием

+5
Ответы (1)
  1. 1 сентября, 03:26
    0
    Var x, s:real; i, n:integer;

    begin

    write ('x = ') ; readln (x) ;

    write ('n = ') ; readln (n) ;

    s:=0; i:=6;

    repeat

    i:=i+1

    s:=s+abs (x-i) / i;

    until i=n;

    writeln ('s = ', s) ;

    end.

    Пример:

    x = 3

    n = 10

    s = 2.56309523809524
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ребят подскажите по информатике S=|x-7|/7+|x-8|/7+|x-9|/9 + ... + |x-n|/n Вычислить сумму циклом с постусловием ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Если выполнения алгоритма заканчивается, когда условие цикла становится истинным, то он называется: 1) циклом с предусловием 2) бесконечность 3) циклом n-раз 4) циклом с постусловием
Нет ответа
Составить программу вычисления суммы всех натуральных чисел меньше 100 и кратных b (от1 до 100). Нужно составить 1 - с циклом с пред условием, 2 - с циклом с пост условием
Ответы (1)
1) Найдите сумму натуральных нечетных чисел не превышающих n! Это нужно сделать циклом for. 2) Составьте программу, которая производит суммирование произвольного количества целых чисел вводимых с клавиатуры.
Ответы (1)
Не был на теме по информатике, нужно сложить как-то циклом 1+56+56+56+56+56+56+56+56+56
Ответы (1)
Создайте программы на языке PascalABC: 1) Введите два числа (например A=5 и В=8) и найдите их произведение, используя цикл с постусловием и только операцию сложения.
Ответы (1)