Задать вопрос
21 марта, 19:14

Разработать программу, которая вычисляет значение одной из заданных функций в указанной точке.

Вид простейшего меню:

Введите код функции:

1 - y = x+1

2 - y = x*x + 1

3 - y = x*x*x + 1

(Сделать надо на паскале помогите плииз)

+3
Ответы (1)
  1. 21 марта, 22:38
    0
    Program task1;

    var

    num: integer;

    x, y: longint;

    flag: byte;

    begin

    writeln ('Введи значение x: ') ;

    read (x) ;

    y:=0;

    flag:=0;

    writeln ('Выбери желаемую функцию: ') ;

    write ('1: y=x+1', #10, '2: y=x*x+1', #10, '3: y=x*x*x+1', #10) ;

    read (num) ;

    if num = 1 then y:=x+1;

    if num = 2 then y:=x*x+1;

    if num = 3 then y:=x*x*x+1;

    if (num 3) or (num = 0) then flag:=1;

    if (num 3) or (num = 0) then writeln ('Invalid number!') ;

    if flag = 0 then writeln ('Значение функции в точке ', x, ' = ', y) else

    write ('Попробуйте ещё раз!') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Разработать программу, которая вычисляет значение одной из заданных функций в указанной точке. Вид простейшего меню: Введите код функции: 1 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В некотором каталоге хранился файл Меню. doc, имевший полное имя F:/Школа/Столовая/Меню. doc. В этом каталоге создали подкаталог Обед и файл Меню. doc переместили в созданный подкаталог. Укажите полное имя этого файла после перемещения.
Ответы (1)
Написать программу на Паскаль: 1) Составить программу, которая при заданных значениях x и y вычисляет функции A с точностью 10^-3 A = ((x*y) / (x+y)) / (1+√ (x²-x-4)) ;
Ответы (1)
Составить программу - калькулятор, которая запрашивает тип математической функции: 1-квадрат, 2-куб, 3 - корень квадратный, 4 - обратная функция, а также аргумент функции x и вычисляет для x соответствующую математическую функцию.
Ответы (1)
Напишите программу в Паскале) написать программу которая вычисляет дату следующего дня. Введите цифрами сегодняшнюю дату (число, месяц, год) 31 12 1998
Ответы (2)
Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию. Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.
Ответы (1)