Задать вопрос
5 июня, 20:46

Напишите программу в Паскале)

написать программу которая вычисляет дату следующего дня.

Введите цифрами сегодняшнюю дату (число, месяц, год) 31 12 1998

+3
Ответы (2)
  1. 5 июня, 20:57
    0
    Program z2;

    var day, month, year:integer;

    begin

    writeln ('Введите число, месяц, год') ;

    readln (day, month, year) ;

    if (year mod 4=0) and (year mod 100 0) or (year mod 100=0) and (year mod 400 = 0) then / / определение висок. года

    begin

    if (month=2) then

    begin

    if (day=29) then

    begin

    day:=1;

    month:=3;

    end

    else

    day:=day+1;

    end

    else if (month=1) or (month=3) or (month=5) or (month=7) or (month=8) or (month=10) then

    begin

    if (day=31) then

    begin

    month:=month+1;

    day:=1;

    end

    else

    day:=day+1;

    end

    else if (month=12) then

    begin

    if (day=31) then

    begin

    year:=year+1;

    month:=1;

    day:=1;

    end

    else

    day:=day+1;

    end

    else

    begin

    if (day=30) then

    begin

    day:=1;

    month:=month+1;

    end

    else

    day:=day+1;

    end;

    end

    else / / проверка обычного года

    begin

    if (month=2) then

    begin

    if (day=28) then

    begin

    day:=1;

    month:=3;

    end

    else

    day:=day+1;

    end

    else if (month=1) or (month=3) or (month=5) or (month=7) or (month=8) or (month=10) then

    begin

    if (day=31) then

    begin

    month:=month+1;

    day:=1;

    end

    else

    day:=day+1;

    end

    else if (month=12) then

    begin

    if (day=31) then

    begin

    year:=year+1;

    month:=1;

    day:=1;

    end

    else

    day:=day+1;

    end

    else

    begin

    if (day=30) then

    begin

    day:=1;

    month:=month+1;

    end

    else

    day:=day+1;

    end;

    end;

    writeln ('Следующий день: ', day, ' ', month, ' ', year) ;

    end.
  2. 5 июня, 23:17
    0
    Const

    dm:array[1 ... 12] of integer = (31,28,31,30,31,30,31,31,30,31,30,31) ;

    var

    d, m, y, dFeb:integer;

    begin

    Write ('Введите дату в формате день месяц год: ') ;

    Read (d, m, y) ;

    if (m=2) and (d>=28) then begin

    if ((y mod 4=0) and (y mod 100 0)) or

    ((y mod 100=0) and (y mod 400 = 0)) then dFeb:=29

    else dFeb:=29;

    if d=dFeb then begin d:=1; Inc (m) end

    else Inc (d) ;

    if m=13 then begin m:=1; Inc (y) end

    end

    else begin

    Inc (d) ;

    if d>dm[m] then begin d:=1; Inc (m) end;

    if m=13 then begin m:=1; Inc (y) end

    end;

    Writeln ('Следующая дата ', d,' ', m,' ', y)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу в Паскале) написать программу которая вычисляет дату следующего дня. Введите цифрами сегодняшнюю дату (число, месяц, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию. Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.
Ответы (1)
Напишите программу (в паскале авс), которая вычисляет число пи с заданной пользователем точностью. Воспользуйтесь данными и условием предыдущей задачи.
Ответы (1)
Помогите написать программу в python Уровень C. Напишите программу, которая получает возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом "год", "года" или "лет". Например, "21 год", "22 года", "25 лет".
Ответы (2)
За год квартплата повышалась дважды: первый образ на 30%, а второй - га 40%. Год назад семья платила квартплату которая составляла 1000 рублей в месяц. Напишите программу, подсчитывающую сегодняшнюю каартплату семьи.
Ответы (1)
За год квартплата повышалась дважды: первый раз на 30%, а во второй-на 40% ... Год назад семья платила квартплату, которая составляла 4500 тнг в месяц ... Напишите программу, подсчитывающую сегодняшнюю квартплату семьи ...
Ответы (1)