Задать вопрос
18 марта, 09:59

Даны отрезки a, b, c, d. Для каждой тройки этих отрезков, из которых можно построить треугольник, напечатать площадь данного треугольника - Pascal ABC.

+3
Ответы (1)
  1. 18 марта, 13:47
    0
    var

    a, b, c, d: real;

    procedure Plo (s: string; x, y, z: real) ;

    var

    sq: real;

    begin

    if ((y + z - x) > 0) and ((x + z - y) > 0) and ((x + y - z) > 0) then

    begin

    sq : = 0.25 * (sqrt ((x + y + z) * (y + z - x) * (x + z - y) * (x + y - z))) ;

    writeln ('Площадь треугольника со сторонами ', s, ' = ', sq:0:3) ;

    end else writeln ('Треугольник со сторонами ', s, ' не существует') ;

    end;

    begin

    write ('a=') ; readln (a) ;

    write ('b=') ; readln (b) ;

    write ('c=') ; readln (c) ;

    write ('d=') ; readln (d) ;

    Plo ('a, b, c', a, b, c) ;

    Plo ('a, b, d', a, b, d) ;

    Plo ('a, c, d', a, c, d) ;

    Plo ('b, c, d', b, c, d) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны отрезки a, b, c, d. Для каждой тройки этих отрезков, из которых можно построить треугольник, напечатать площадь данного треугольника - ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)