Задать вопрос
23 декабря, 00:21

Составить программу в с++

Дано натуральное число:

1) найти кол-во четных цифр этого числа

2) верно ли, что в Данном числе встречается A и B (числа A и B вводится с клавиатуры)

+2
Ответы (1)
  1. 23 декабря, 03:53
    0
    1)

    #include

    #include

    using namespace std;

    int main () {

    int a, k = 0;

    cin >> a;

    for (int b = abs (a) ; b > 0; b/=10)

    if (b%10%2 = = 0) k++;

    cout << k << endl;

    }

    2)

    #include

    #include

    using namespace std;

    int main () {

    int n, a, b;

    bool flagA = false, flagB = false;

    cin >> n >> a >> b;

    for (int d = abs (n) ; d > 0; d/=10) {

    if (d%10 = = a) flagA = true;

    else if (d%10 = = b) flagB = true;

    }

    cout << ((flagA && flagB) ? "true" : "false") << endl;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу в с++ Дано натуральное число: 1) найти кол-во четных цифр этого числа 2) верно ли, что в Данном числе встречается A и B ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Дано натуральное число. Определить: а) сколько раз в нем встречается цифра а; б) количество его цифр, кратных z (значение z вводится с клавиатуры; z 2, 3, 4) ; в) сумму его цифр, больших a (значение a вводится с клавиатуры; 0 a 8) ;
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Паскаль 1. Дано натуральное число. Верно ли, что в данном числе сумма цифр больше В, а само число делится на В (В вводится с клавиатуры). 2. Квадраты некоторых трехзначных чисел оканчиваются тремя цифрами, которые как раз и составляют исходные числа.
Ответы (1)
1) Найти минимальное число, большее 300, которое нацело делится на 19.2) С клавиатуры вводится натуральное число n. Найти количество цифр этого числа, их сумму, количество четных и нечетных цифр, сколько цифр в числе делится на 3.
Ответы (1)