Задать вопрос
14 сентября, 01:22

Написать программу, нахождение среднего значения построчно в матрице 7*5.

+3
Ответы (1)
  1. 14 сентября, 03:44
    0
    Var

    m : array [1 ... 7,1 ... 5] of Real;

    i, j : Byte;

    sr : Real;

    Begin

    For i:=1 to 7 do

    Begin

    sr:=0;

    For j:=1 to 5 do

    Begin

    m[i, j]:=Random (100) ;

    Write (m[i, j]:5) ;

    sr:=sr+m[i, j];

    end;

    Writeln (' Ср. знач. строки: ', sr/5:5:1) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, нахождение среднего значения построчно в матрице 7*5. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Упорядочить каждый столбец матрицы по возрастанию. Массив размером M*N, элементы которого задаются датчиком случайных чисел на интервале [-17; 26]. Программа выводит начальный вариант массива построчно, затем отсортированный массив построчно.
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Что осуществляется с помощью этих трех действий: a=a+b b=a-b a=a-b a) нахождение суммы и разности двух переменных б) нахождение среднеарифметического двух переменных в) обмен значениями двух переменных г) нахождение максимального значения двух
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Напишите программу, которая находит в матрице столбцы, в которых есть элемент, равный максимальному. Входные данные В первой строке записаны через пробел размеры матрицы: количество строк N и количество столбцов M (1 ≤ N, M ≤ 100).
Ответы (1)