Задать вопрос
12 сентября, 02:47

Упорядочить каждый столбец матрицы по возрастанию. Массив размером M*N, элементы которого задаются датчиком случайных чисел на интервале [-17; 26].

Программа выводит начальный вариант массива построчно, затем отсортированный массив построчно.

+2
Ответы (1)
  1. 12 сентября, 04:38
    0
    program nomerstolb;

    Var a: array[1 ... 50,1 ... 50] of integer;

    b: array[1 ... 50] of integer;

    i, j, m, n, max, jmax: integer;

    Begin

    Write (‘сколько строк?’) ; Readln (m) ;

    Write (‘сколько столбцов?’) ; Readln (n) ;

    For i:=1 to m do

    begin

    For j:=1 to n do

    begin

    write (‘a[‘, i,’,’, j,’]=’) ; readln (a[i, j]) ;

    end;

    for j:=1 to m do

    begin

    b[j]:=0;

    for i:=1 to n do

    if a[i, j]<0 then b[j]:=b[j]+1;

    end;

    max:=b[1]; jmax:=1;

    For j:=2 to n do

    begin

    if b[j]>max then

    begin

    max:=b[j]; jmax:=j;

    end;

    end;

    writeln (‘Наибольшее количество отрицательных элементов в ‘; jmax; ‘столбце’) ;

    end;

    end.

    9. Упорядочить каждый столбец матрицы по возрастанию. Массив размером МхN, элементы которого задаются датчиком случайных чисел на интервале [-17; 26].

    program porydok;

    Var a: array[1 ... 50,1 ... 50] of integer;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Упорядочить каждый столбец матрицы по возрастанию. Массив размером M*N, элементы которого задаются датчиком случайных чисел на интервале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачу на массивы, любую! 1. Найти сумму элементов в каждом столбике массива MxN, элементы которого задаются датчиком случайных чисел на интервале [-19; 20] 2.
Ответы (1)
Заполнить массив А (13) датчиком случайных чисел в интервале от 0 до 40 определить количество элементов массива не превосходящих по величине число В число В задается датчиком случайных чисел в интервале от 0 до 20
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)