Задать вопрос
24 марта, 09:33

1. даны два натуральных числа а и б требуется определить сумму чисел от а до б.

2. дано натуральное число а, требуется определить есть ли в этом числе цифра 3.

3. начальный вклад в банк составил а рублей. через сколько лет он станет больше б рублей. (каждый год вклад увеличивается на 3%). Паскаль abc

+2
Ответы (1)
  1. 24 марта, 11:34
    0
    Var

    a, b:integer;

    S:real;

    Begin

    S:=0;

    Write ('a = ') ;

    ReadLn (a) ;

    Write ('b = ') ;

    ReadLn (b) ;

    For b: = a to b do

    S:=S+b;

    WriteLn ('S = ', S) ;

    End.

    Var

    A, k:integer;

    Begin

    Write ('a = ') ; ReadLn (A) ;

    k:=0;

    While A > 0 do

    Begin

    if A mod 10 = 3 then k:=1;

    A:=A div 10

    End;

    if k = 1 then Write ('Есть')

    else Write ('Нет')

    End.

    Var

    A, B:real;

    k:integer;

    Begin

    Write ('a = ') ; ReadLn (A) ;

    Write ('b = ') ; ReadLn (B) ;

    While A < = B do

    Begin

    k:=k+1;

    A:=A*1.03;

    End;

    WriteLn (k) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. даны два натуральных числа а и б требуется определить сумму чисел от а до б. 2. дано натуральное число а, требуется определить есть ли в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Реализуйте решение задачи, программируя на Паскале. Начальный вклад в банк составляет x=300000 рублей. Через сколько лет он станет больше y=550500 рублей? Каждый год вклад увеличивается на 11%.
Ответы (1)
Составить программу, позволяющую решить задачу. Начальный вклад в банк составила рублей. Через сколько лет он станет больше b рублей? Каждый год вклад увеличивается на 3%.
Ответы (1)
Паскаль. 1) В банк положили вклад N рублей. Каждый месяц вклад увеличивается на 1%. Определить размер вклада через 5 лет. 2) Дано натурального число. Найти сумму его делителей, не кратных 3. 3) Дано натурального число. Найти его максимальную цифру.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Паскаль Помогите доделать задачу Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше.
Ответы (1)