Задать вопрос
30 сентября, 00:30

Паскаль

Помогите доделать задачу

Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.

Входные данные

Программа получает на вход три натуральных числа: x, p, y.

Выходные данные

Программа должна вывести одно целое число.

program u1;

var

x, p, s, n: integer;

y:real;

begin

read (x) ;

read (p) ;

read (y) ;

s:=0;

s: = x + (x*p) div 100;

n: = 1;

while (s < y) do

begin

s : = s + ((s*p) div 100) ;

n: = n + 1;

end;

writeln (n) ;

readln;

end.

Здесь где-то есть недоработка.

+1
Ответы (1)
  1. 30 сентября, 02:07
    0
    Program u1;

    var

    x, p, y, s, n: integer;

    begin

    readln (x, p, y) ;

    s:=x;

    n: = 0;

    while (s < y) do

    begin

    s : = s+trunc ((s*p) / 100) ;

    n: = n+1;

    end;

    writeln (n) ;

    end.

    Пример:

    100 10 500

    18
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль Помогите доделать задачу Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать так чтобы Writeln был заменен другим словом и повторялься не больше двух раз program choise; var N_M:integer; writeln (' введи номер месяца ') ; readln (N_M) ; case N_M of 1:writeln (' январь ') ; 2:writeln (' февраль ') ;
Ответы (1)
Помогите! Когда я ввожу ответ на вопрос, оно не отвечает на него! Это Паскаль Program Programm; var n:string; a:integer; b:integer; c:integer; answer: integer; begin write ('Как вас зовут:') ; readln (n) ; writeln ('Привет, ', n,'!
Ответы (1)
Сократите эту программу program sr; var a, b, c : real; y, x, xb, xc : real; na, nb, nc: integer; function stup (x: real; n: integer) : real; var i: integer; k: real; begin k:=1; for i : = 1 to n do k : = k * x; stup : = k; end;
Ответы (1)
Что я неправильно написал? var a, b, c, d: real; begin writeln (' введи число a') ; readln (a) ; writeln ('введи число b') ; readln (b) ; writeln ('введи число c') ; readln (c) ; d:=a; a:=c; writeln (a) ; c:=b; writeln (c) ; b:=d; writeln (b) ; end.
Ответы (1)
Объясните строчку (c:=10*c+a mod 10; a : = a div 10;) program pr36; function qwer (var a, b: integer) : integer; var c: integer; begin c:=0; while a > 0 do begin c:=10*c+a mod 10; a : = a div 10; end; qwer: = c; end; var a, b: integer;
Ответы (1)