Задать вопрос
30 сентября, 00:49

Сравнить остаток деления b на a с переменной а

а:=5

b:=23

Вывод: остаток > или < a

Работу выполнить в Паскале

+5
Ответы (1)
  1. 30 сентября, 03:06
    0
    Const

    a=5;

    b=23;

    var c, n:real;

    begin

    c:=b/a;

    c:=trunc (c) ;

    c:=c*a;

    n:=b-c;

    if c>a then writeln ('остаток больше чем а')

    else writeln ('остаток меньше а') ;

    end.

    вместо a и b можно вводить любые числа (с отрицательными не тестил).
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сравнить остаток деления b на a с переменной а а:=5 b:=23 Вывод: остаток > или < a Работу выполнить в Паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Запишите на алгоритмическом языке алгоритм, в результате которого переменной A будет присвоено значение переменной B, переменной B-значение переменной C, а переменной C-значение переменной A. Используйте не более одной промежуточной переменной.
Ответы (1)
Составить программу, которая находит минимальное натуральное число х, такое, что остаток от деления х на 10 равен 9, остаток от деления х на 9 равен 8, остаток от деления х на 8 равен 7, ... остаток от деления х на 2 равен 1.
Ответы (1)
Автомат получает на вход нечётное число X. По этому числу строится трёхзначное число Y по следующим правилам. 1. Первая цифра числа Y (разряд сотен) - остаток от деления X на 4. 2. Вторая цифра числа Y (разряд десятков) - остаток от деления X на 3.
Ответы (1)
Сколько промежуточных переменных потребуется для того, чтобы переменной А было присвоено значение В, переменной В - значение переменной С, а переменной С - значение переменной А? Запишите соответствующий алгоритм на алгоритмическом языке.
Ответы (1)
Задача1 Введите числа в переменные a, b и c и напишите программу, которая меняет местами значения переменных по следующей схеме, чтобы в переменной а оказалось первоначальное значение переменной с, в переменной b - значение а, в переменной с -
Ответы (1)