Задать вопрос
17 мая, 02:18

Дана строка символов. Определить длину строки. Если длина строки <=20, то найти в строке порядковый номер символа. Нужен Паскаль!1

+1
Ответы (1)
  1. 17 мая, 02:49
    0
    Var

    S:string;

    C:char;

    i:integer;

    Begin

    Write ('Введите строку: ') ;

    ReadLn (S) ;

    Write ('Введите символ: ') ;

    ReadLn (C) ;

    For i: = 1 to S. Length do

    if S[i] = C then

    Write (i,' ')

    End.

    Пример:

    Введите строку: Дана строка символов. Определить длину строки. Если длина строки <=20, то найти в строке порядковый номер символа *

    Введите символ: а

    2 4 11 57 76 113
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана строка символов. Определить длину строки. Если длина строки ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Синвейн про информатику (1 строка информатика 2 строка два прилагательных 3 строка три глагола 4 строка фраза, несущая определённый смысл 5 строка вывод в одном слове) Стоки не должны рифмоваться
Ответы (1)
Дана матрица размера M х N. Вывести ее элементы в следующем порядке: первая строка слева направо, вторая строка справа налево, третья строка слева направо, четвертая строка справа налево и т. д. в c++, code blocks
Ответы (1)
5.1 Ввести с клавиатуры строку символов. Признак окончания ввода строки - нажатие клавиши "Ввод". Программа должна определить длину введенной строки L, и, если длина L >6, то выделяется подстрока в { } скобках. 5.2 Дана строка.
Ответы (1)
Дана строка, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в ровно один раз. Формат входных данных Во входном файле дана строка.
Ответы (1)