Задать вопрос
19 августа, 05:47

5.1 Ввести

с клавиатуры строку символов. Признак окончания ввода строки - нажатие клавиши

"Ввод". Программа должна определить длину введенной строки L, и, если

длина L >6, то выделяется подстрока в { } скобках.

5.2 Дана

строка. Подсчитать количество букв k в последнем его слове.

+3
Ответы (1)
  1. 19 августа, 08:48
    0
    var

    l, a, b:integer;

    s: string;

    begin

    write ('Введите строку: ') ;

    readln (s) ;

    l:=length (s) ;

    writeln ('L=', l) ;

    if l>6 then

    begin

    a:=pos (' (', s) ;

    b:=pos (') ', s) ;

    if (a>0) and (b>0) then writeln (copy (s, a+1, b-a-1)) ;

    if (a=0) and (b>0) then writeln ('Скобка не открыта') ;

    if (a>0) and (b=0) then writeln ('Скобка не закрыта') ;

    if (a=0) and (b=0) then writeln ('Текста в скобках нет') ;

    end;

    end.

    var

    n, i, k:integer;

    s, t: string;

    begin

    write ('Введите строку: ') ;

    readln (s) ;

    t:=s;

    repeat

    i:=pos (' ', t) ;

    delete (t, 1, i) ;

    until i=0;

    k:=length (t) ;

    for i:=1 to k do

    if t[i]='k' then n:=n+1;

    writeln ('Кол-во букв k: ', n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «5.1 Ввести с клавиатуры строку символов. Признак окончания ввода строки - нажатие клавиши "Ввод". Программа должна определить длину ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
1. Переключение клавиатуры с режима ввода латинских букв на режим ввода русских букв и обратно? 2. переключение клавиатуры с режима ввода строчных букв на режим ввода прописных букв и обратно? 3.
Ответы (1)
Ввести строку с клавиатуры ввести символ с клавиатуры используя оператора ввода задать некоторую строку содержашая 15-25 символов определить длину строки вывести на экран сам символ и позицую в каторой он найден (также надо задать любое
Ответы (1)
Напишите программу, которая считывает с клавиатуры строку и выводит фразу: "Слово [введённая строка] имеет длину [длина введённой строки]". Пример Ввод Вывод собака Слово собака имеет длину 6 программа питон
Ответы (1)
Дана строка. определииь сколько раз в нее входит подстрока "ель". Ввести с клавиатуры строку символов
Ответы (1)