Задать вопрос
9 августа, 20:15

Уровень B. Заполните массив случайными числами в интервале [0,5]. Определить, есть ли в нем элементы с одинаковыми значениями, стоящие рядом.

Пример:

Массив:

1 2 3 3 2 1

Есть: 3

Пример:

Массив:

1 2 3 4 2 1

Нет

+3
Ответы (1)
  1. 9 августа, 21:35
    0
    Program n1;

    const n=6;

    var a, i: integer;

    m:array [1 ... n] of integer;

    begin

    randomize;

    write ('иcходный массив:') ;

    for i:=1 to n do

    begin

    m[i]:=random (6) ;

    write (m[i],' ') ;

    end;

    writeln;

    a:=0;

    for i:=1 to n-1 do

    begin

    if m[i]=m[i+1]

    then begin

    if a=0

    then begin

    write ('есть: ') ;

    a:=1;

    end;

    write (m[i],' ') ;

    end;

    end;

    if a=0

    then writeln ('нет') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Уровень B. Заполните массив случайными числами в интервале [0,5]. Определить, есть ли в нем элементы с одинаковыми значениями, стоящие ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С помощью Паскаля: 1. Заполните массив случайными числами в интервале [0; 100] и подсчитайте отдельно среднее значение всех элементов, которые меньше 50, и среднее значение всех элементов, которые больше или равны 50. 2.
Ответы (1)
1) Составте программуб которая заполняет массив а[1 ... 10] случайными целыми числами в диапозоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с четными значениями на 1.
Ответы (1)
Решить задачи с помощью Паскаля: 1. Заполнить массив из 10 элементов случайными числами в интервале [0 ... 100] и отсортировать его по последней цифре. 2. Заполнить массив из 10 элементов случайными числами в интервале [0 ...
Ответы (2)
Помогите решить задачи по икт. 1 заполнителя массив из 10 элементов случайными числами в интервале [-10 ... 10] и выполнить циклический сдвиг вправо. 2 заполнить массив из 10 элементов случайными числами в интервале [0 ...
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)