Задать вопрос
8 августа, 12:32

Помогите решить задачи по икт.

1 заполнителя массив из 10 элементов случайными числами в интервале [-10 ... 10] и выполнить циклический сдвиг вправо.

2 заполнить массив из 10 элементов случайными числами в интервале [0 ... 100) и отсортировать её по возрастанию

+5
Ответы (1)
  1. 8 августа, 15:07
    0
    Задача 1.

    const

    n = 10;

    var

    a: array[1 ... n] of integer;

    i, s: integer;

    begin

    Randomize;

    Writeln ('Элементы массива') ;

    for i : = 1 to n do

    begin

    a[i] : = Random (21) - 10;

    Write (a[i]:4) ;

    end;

    Writeln;

    s : = a[n];

    for i : = n - 1 downto 1 do a[i + 1] : = a[i];

    a[1] : = s;

    Writeln ('После циклического сдвига вправо на 1') ;

    for i : = 1 to n do Write (a[i]:4) ;

    Writeln

    end.

    Тестовое решение:

    Элементы массива

    -2 - 1 7 10 2 - 7 9 - 6 - 5 - 10

    После циклического сдвига вправо на 1

    -10 - 2 - 1 7 10 2 - 7 9 - 6 - 5

    Задача 2.

    const

    n = 10;

    var

    a: array[1 ... n] of integer;

    i, j, t: integer;

    begin

    Randomize;

    Writeln ('Исходный массив') ;

    for i : = 1 to n do

    begin

    a[i] : = random (101) ;

    Write (a[i]:4)

    end;

    Writeln;

    for i : = 1 to n-1 do

    for j : = 1 to n-i do

    if a[j] > a[j+1] then

    begin t : = a[j]; a[j] : = a[j+1]; a[j+1] : = t end;

    Writeln ('Отсортированный по возрастанию массив') ;

    for i : = 1 to n do Write (a[i]:4) ;

    Writeln

    end.

    Тестовое решение:

    Исходный массив

    31 60 14 17 46 6 46 97 60 88

    Отсортированный по возрастанию массив

    6 14 17 31 46 46 60 60 88 97
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить задачи по икт. 1 заполнителя массив из 10 элементов случайными числами в интервале [-10 ... 10] и выполнить циклический ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решить задачи с помощью Паскаля: 1. Заполнить массив из 10 элементов случайными числами в интервале [0 ... 100] и отсортировать его по последней цифре. 2. Заполнить массив из 10 элементов случайными числами в интервале [0 ...
Ответы (2)
Язык программирования: Паскаль. Написать программу. Заполнить массив из 10 элементов случайными числами в интервале [0 ... 100] и отсортировать первую половину по возрастанию, а вторую - по убыванию.
Ответы (1)
дано 2 одномерных массива размером 20 ячеек первый массив заполнить случайными числами от 10 до 50 второй заполнить случайными числами от 30 до 90 первый массив отсортировать по возврастанию второй по убыванию посчитать среднее арифметическое
Ответы (1)
С помощью Паскаля: 1. Заполните массив случайными числами в интервале [0; 100] и подсчитайте отдельно среднее значение всех элементов, которые меньше 50, и среднее значение всех элементов, которые больше или равны 50. 2.
Ответы (1)
Заполнить двумерный массив 3x4 случайными числами в интервале [-50 ... 50] и отсортировать построчно по возрастанию.
Ответы (2)