Задать вопрос
10 марта, 15:52

Язык программирования: Паскаль. Написать программу.

Заполнить массив из 10 элементов случайными числами в интервале [0 ... 100] и отсортировать первую половину по возрастанию, а вторую - по убыванию.

+3
Ответы (1)
  1. 10 марта, 17:55
    0
    var a:array[1 ... 10]of integer;

    i, j, k:integer;

    begin

    for i:=1 to 10 do a[i]:=random (101) ;

    for i:=1 to 10 do write (a[i],' ') ;

    writeln;

    for i:=1 to 5 do

    for j:=1 to 4 do

    if a[j]>a[j+1] then begin

    k:=a[j];

    a[j]:=a[j+1];

    a[j+1]:=k;

    end;

    for i:=1 to 5 do

    for j:=7 to 10 do

    if a[j]>a[j-1] then begin

    k:=a[j];

    a[j]:=a[j-1];

    a[j-1]:=k;

    end;

    for i:=1 to 10 do write (a[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Язык программирования: Паскаль. Написать программу. Заполнить массив из 10 элементов случайными числами в интервале [0 ... 100] и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решить задачи с помощью Паскаля: 1. Заполнить массив из 10 элементов случайными числами в интервале [0 ... 100] и отсортировать его по последней цифре. 2. Заполнить массив из 10 элементов случайными числами в интервале [0 ...
Ответы (2)
Помогите решить задачи по икт. 1 заполнителя массив из 10 элементов случайными числами в интервале [-10 ... 10] и выполнить циклический сдвиг вправо. 2 заполнить массив из 10 элементов случайными числами в интервале [0 ...
Ответы (1)
дано 2 одномерных массива размером 20 ячеек первый массив заполнить случайными числами от 10 до 50 второй заполнить случайными числами от 30 до 90 первый массив отсортировать по возврастанию второй по убыванию посчитать среднее арифметическое
Ответы (1)
С помощью Паскаля: 1. Заполните массив случайными числами в интервале [0; 100] и подсчитайте отдельно среднее значение всех элементов, которые меньше 50, и среднее значение всех элементов, которые больше или равны 50. 2.
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)