Задать вопрос
17 февраля, 21:46

Решить задачи с помощью Паскаля:

1. Заполнить массив из 10 элементов случайными числами в интервале [0 ... 100] и отсортировать его по последней цифре.

2. Заполнить массив из 10 элементов случайными числами в интервале [0 ... 100] и отсортировать первую половину по возрастанию, а вторую - по убыванию. Здесь решать лучше методом выбора.

+4
Ответы (2)
  1. 18 февраля, 00:33
    0
    2) Сортирую не методом выбора, а пузырьковым методом, т. к. мне неизвестна формулировка "метод выбора"

    program z1;

    var

    mas:array[1 ... 10] of Integer;

    m, n, temp:integer;

    begin

    randomize;

    for i:=1 to 10 do

    begin

    mas[i]:=random (100) ;

    end;

    for i:=1 to 4 do if mas[i]>mas[i+1] then

    begin

    temp:=mas[i+1];

    mas[i+1]:=mas[i];

    mas[i]:=temp;

    end;

    for i:=6 to 9 do if mas[i]
    begin

    temp:=mas[i+1];

    mas[i+1]:=mas[i];

    mas[i]:=temp;

    end;

    end.

    Если нужен еще и вывод на экран - то дописываете перед end. следующее: for i:=1 to 10 do writeln (mas[i])

    Насчет первого. Мне непонятна формулировка "отсортировать по последней цифре"
  2. 18 февраля, 01:24
    0
    Var i, j:integer;

    mas:array [1 ... 10] of integer;

    begin

    randomize;

    for i: = 1 to 10 do

    mas[i]:=random (101) ;

    for j:=1 to 10-1 do

    for i:=1 to 10-j do

    if mas[i] mod 10 > mas[i+1] mod 10 then

    swap (mas[i], mas[i+1]) ;

    for i:=1 to 10 do

    writeln (mas[i]) ;

    end.

    2)

    var a:array[1 ... 10] of Integer;

    i, j:Integer;

    begin

    randomize;

    for i:=1 to 10 do

    a[ i]:=random (101) ;

    for i:=1 to 4 do

    for j:=i+1 to 5 do

    if a[ i] > a[ j] then

    swap (a[i], a[j]) ;

    for i:=5 to 9 do

    for j:=i+1 to 10 do

    if a[ i] < a[ j] then

    swap (a[i], a[j]) ;;

    for i:=1 to 10 do

    write (a[ i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решить задачи с помощью Паскаля: 1. Заполнить массив из 10 элементов случайными числами в интервале [0 ... 100] и отсортировать его по ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Язык программирования: Паскаль. Написать программу. Заполнить массив из 10 элементов случайными числами в интервале [0 ... 100] и отсортировать первую половину по возрастанию, а вторую - по убыванию.
Ответы (1)
Помогите решить задачи по икт. 1 заполнителя массив из 10 элементов случайными числами в интервале [-10 ... 10] и выполнить циклический сдвиг вправо. 2 заполнить массив из 10 элементов случайными числами в интервале [0 ...
Ответы (1)
С помощью Паскаля: 1. Заполните массив случайными числами в интервале [0; 100] и подсчитайте отдельно среднее значение всех элементов, которые меньше 50, и среднее значение всех элементов, которые больше или равны 50. 2.
Ответы (1)
дано 2 одномерных массива размером 20 ячеек первый массив заполнить случайными числами от 10 до 50 второй заполнить случайными числами от 30 до 90 первый массив отсортировать по возврастанию второй по убыванию посчитать среднее арифметическое
Ответы (1)
Сортировка массивов по возрастанию и по убыванию. Массив задается от датчика случайных чисел random (). Сортировать один и тот же исходный массив и по убыванию и по возрастанию значений элементов.
Ответы (1)