Задать вопрос
5 июля, 01:29

С клавиатуры поочередно вводятся целые числа. Вычислите сумму положительных чисел. Признаком конца ввода чисел является число 0.

+2
Ответы (1)
  1. 5 июля, 03:59
    0
    Var

    A:integer;

    S:real;

    Begin

    S:=0;

    Repeat

    Read (A) ;

    if A>0 then S:=S+A;

    Until A=0;

    Write ('S = ', S) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры поочередно вводятся целые числа. Вычислите сумму положительных чисел. Признаком конца ввода чисел является число 0. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Переключение клавиатуры с режима ввода латинских букв на режим ввода русских букв и обратно? 2. переключение клавиатуры с режима ввода строчных букв на режим ввода прописных букв и обратно? 3.
Ответы (1)
С клавиатуры вводятся целые числа признаком конца ввода является 0. найти сумму тех чисел среди введённых, которое больше 10
Ответы (1)
С клавиатуры вводятся целые числа. Признаком конца ввода чисел является 0. изменить знак отрицательных чисел на положительный. Результаты вывести на экран.
Ответы (1)
Написать программу для паскаль. С клавиатуры вводятся целые числа. Признаком конца ввода является 0. Изменить знак отрицательных чисел на противоположный. Результаты вывести на экран.
Ответы (2)
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)