Задать вопрос
6 декабря, 22:03

Дана строка, заканчивающаяся точкой. Подсчитать, сколько в ней слов.

+3
Ответы (1)
  1. 6 декабря, 22:13
    0
    Var

    S:string;

    i, k:integer;

    Begin

    Write ('Введите строку: ') ; ReadLn (S) ;

    k:=0;

    i:=1;

    Repeat

    if (S[i] = ' ') or (S[i] = ',') or (S[i] = ':') or (S[i] = '; ') or (S[i] = '?') or (S[i] = '!') then

    if not ((S[i+1] = ' ') or (S[i+1] = ',') or (S[i+1] = ':') or (S[i+1] = '; ') or (S[i+1] = '?') or (S[i+1] = '!')) then

    k:=k+1;

    i:=i+1

    Until S[i] = '.';

    WriteLn ('Количество слов: ', k+1) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана строка, заканчивающаяся точкой. Подсчитать, сколько в ней слов. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Синвейн про информатику (1 строка информатика 2 строка два прилагательных 3 строка три глагола 4 строка фраза, несущая определённый смысл 5 строка вывод в одном слове) Стоки не должны рифмоваться
Ответы (1)
Дана матрица размера M х N. Вывести ее элементы в следующем порядке: первая строка слева направо, вторая строка справа налево, третья строка слева направо, четвертая строка справа налево и т. д. в c++, code blocks
Ответы (1)
Дана строка, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в ровно один раз. Формат входных данных Во входном файле дана строка.
Ответы (1)
Дана строка S, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в S ровно один раз. Формат входных данных Во входном файле дана строка S.
Ответы (1)