Задать вопрос
28 августа, 02:16

Вопрос по информатике. Написать программу на языке FreePascal. Дан массив определённой длины, в котором могут быть как положительные, так и отрицательные числа. Проинициализировать массив и найти кол-во элементов массива до первого отрицательного и сумму элементов после него

+4
Ответы (1)
  1. 28 августа, 06:12
    0
    Uses Crt;

    Const

    N = 13;

    Var

    A:array[1 ... N] of integer;

    i, k:integer;

    S:real;

    Begin

    Randomize;

    ClrScr;

    For i: = 1 to N do

    Begin

    A[i]:=random (21) - 10;

    Write (A[i],' ')

    End;

    WriteLn;

    i:=1;

    k:=0;

    While (A[i]>=0) and (i
    Begin

    k:=k+1;

    i:=i+1

    End;

    if A[i]>=0 then k:=k+1;

    WriteLn ('k = ', k) ;

    S:=0;

    For i: = i+1 to N do

    S:=S+A[i];

    WriteLn ('S = ', S:0:3) ;

    ReadLn

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вопрос по информатике. Написать программу на языке FreePascal. Дан массив определённой длины, в котором могут быть как положительные, так и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)