Задать вопрос
18 апреля, 11:53

Написать в тетради программу, в которой пользователь вводит целое 3-хзначное число, необходимо найти сумму его цифр

+4
Ответы (1)
  1. 18 апреля, 15:05
    0
    Var s: integer;

    begin

    readln (s) ;

    s: = (s div 100) + ((s div 10) mod 10) + (s mod 10) ;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать в тетради программу, в которой пользователь вводит целое 3-хзначное число, необходимо найти сумму его цифр ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
Помогите с программой. Пользователь вводит с клавиатуры сумму, которая у него есть. Далее"садится за рулетку". Программа спрашивает, какая ставка и на что ставит. пользователь. Ставка идет на конкретное число (от 1 до 36).
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Напишите программу для Pascal 1) Пользователь вводит число, количество цифр в нем неизвестно, но последняя цифра = 0. Посчитать количество четных положительных цифр в этом числе.
Ответы (1)