Задать вопрос
28 августа, 04:36

Помогите написать программу в паскаль АBC задание:

Напишите программу которая в последовательности натуральных чисел определяет чётное минимальное число. При этом кол-во введённых чисел неизвестно. Но не превышает 1000. Введённые числа не превышают 30000. В последовательности всегда имеется чётное число. Программа должна вывести это одно минимальное чётное число.

+1
Ответы (1)
  1. 28 августа, 05:51
    0
    Var N, A, Min:integer;

    Begin

    Min:=30001;

    Read (N) ;

    For N: = 1 to N do

    Begin

    Read (A) ;

    if (A mod 2 = 0) and (A < Min) then Min:=A;

    End;

    WriteLn (Min)

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу в паскаль АBC задание: Напишите программу которая в последовательности натуральных чисел определяет чётное ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
Напишите программу, которая в последовательности натуральных чисел определяет минимальное четное число. Программа получает на вход кол-во чисел в последовательности, а затем сами числа. В последовательности всегда имеется четное число.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)