Задать вопрос
26 октября, 17:37

Дано натуральное число N. составьте программу, которая выводит все числа от 1 по N, у которых последняя цифра кратная 3

+2
Ответы (2)
  1. 26 октября, 18:08
    0
    Var

    n, d:integer;

    f:Text;

    begin

    Assign (f,'input. txt') ; Reset (f) ;

    Read (f, n) ;

    Assign (f,'output. txt') ; Rewrite (f) ;

    d:=n mod 10;

    while n>=10 do n:=n div 10;

    if n>d then Writeln (f,'>')

    else

    if n=d then Writeln (f,'=') else Writeln (f,'<') ;

    Close (f)

    end.

    TXT
  2. 26 октября, 20:57
    0
    Var n, i: integer;

    begin

    i : = 3;

    while i < = n do

    begin

    write (i, ' ') ;

    i : = i + 10;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число N. составьте программу, которая выводит все числа от 1 по N, у которых последняя цифра кратная 3 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Помогите по программе paskal: 1. дано целое число. напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора результат 2. дано целое число.
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Задача 1) Даны два числа а и b. Написать программу, которая находит меньшее из них и выводит на экран соответствующий результат. Задача 2) Дано целое число.
Ответы (1)