Задать вопрос
23 декабря, 07:54

Дана матрица размером 3*4. Найти сумму элементов матрицы. В паскале. Обязательно использовать функцию или процедуру

+1
Ответы (1)
  1. 23 декабря, 08:01
    0
    Var c:integer;

    procedure generate (var c:integer) ;

    var ar:array[1 ... 3,1 ... 4] of integer;

    a, b:integer;

    begin;

    for a:=1 to 3 do

    begin;

    writeln;

    for b:=1 to 4 do

    begin;

    ar[a, b]:=random (10) ;

    c+=ar[a, b];

    write (ar[a, b]:4) ;

    end;

    end;

    end;

    begin;

    randomize;

    writeln ('Matrix:') ;

    generate (c) ;

    writeln;

    writeln ('Result', c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана матрица размером 3*4. Найти сумму элементов матрицы. В паскале. Обязательно использовать функцию или процедуру ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана матрица размерностью nxn найти Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы.
Ответы (1)
1) Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного. 2) дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов.
Ответы (1)
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)
6 вариант. Даны две квадратные матрицы А и В размером 3 х3. Требуется найти С = В - А. Дана вещественная матрица А (N. M). Составить программу замены всех отрицательных элементов матрицы на элемент, имеющий максимальное значение.
Ответы (1)
1) Даны квадратная матрицы А размером 3 х3 и число t. Требуется найти С=t*А. 2) Дана вещественная матрица А (N, M). Составить программу нахождения максимального отрицательного элемента матрицы и нахождения его местоположения.
Ответы (1)