Задать вопрос
23 марта, 12:36

Даны два натуральных числа m и n. Проверить, есть ли в записи числа m цифры, одинаковые с цифрами в записи числа n.

+3
Ответы (1)
  1. 23 марта, 14:55
    0
    Var n, m:integer;

    mn:set of integer;

    b:boolean;

    begin

    write ('n = ') ; readln (n) ;

    write ('m = ') ; readln (m) ;

    mn:=[];

    while n>0 do

    begin

    mn:=mn+[n mod 10];

    n:=n div 10;

    end;

    b:=false;

    while m>0 do

    begin

    if (m mod 10) in mn then b:=true;

    m:=m div 10;

    end;

    if b then writeln ('Да') else writeln ('Нет') ;

    end.

    Пример:

    n = 13579

    m = 6541

    Да
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны два натуральных числа m и n. Проверить, есть ли в записи числа m цифры, одинаковые с цифрами в записи числа n. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
1) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. 2) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).
Ответы (1)
В PascalABC Напишите программу, которая выводит все простые числа в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000), у которых первая и последняя цифры десятичной записи одинаковые.
Ответы (1)
Дано уравнение: mm + n = nxx, в котором цифры заменены на буквы. Разные буквы означают разные цифры, одинаковые буквы - одинаковые цифры. Определи, чему будет равно значение выражения: m+2*n+3*x? А) 10 Б) 11 В) 20 Г) 21 Д) 22
Ответы (1)
Сумма цифр. Даны два числа А и В. Подсчитайте кол-во натуральных чисел на отрезке от А до В, сумма цифр которых четна. Программа получает на вход два натуральных числа А и В, не превосходящих 10^9^ А
Ответы (1)