Задать вопрос
12 декабря, 11:16

Составьте программу Pascal находящую количество делителей натурального числа N

+2
Ответы (1)
  1. 12 декабря, 13:01
    0
    Program wer;

    var k, i, n: integer;

    begin

    writeln ('vvedi natur chislo') ;

    readln (n) ;

    if n>=1 then

    begin

    for i:=1 to n do

    if n/i=n div i then k:=k+1;

    writeln ('kol-vo delitelej=', k) ;

    end else writeln ('eto chislo ne natur') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу Pascal находящую количество делителей натурального числа N ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. составить программу и алгоритм находящую сумму цифр трехзначного числа 2. составить программу и алгоритм находящую все простые делители заданного числа
Ответы (1)
Составьте программу, находящую количество делителей натурального числа N. Указание. Число х является делителем числа N, если выполняется условие N mod x=0. Это паскаль
Ответы (1)
Проверить являются ли два введенных числа дружественными. Дружественные числа - пара чисел, каждое из которых равно сумме собственных делителей другого (Делителем числа называется всякий его делитель, отличный от самого числа) Дружественные числа
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)