Задать вопрос
2 августа, 09:38

Заполнить двумерный массив с помощью датчика случ. чисел. Сформировать одномерный массив, закинуть произведение четных элементов по каждому столбику. Найти сумму элементов двумерного, для нечетных номеров столбика.

+3
Ответы (1)
  1. 2 августа, 11:39
    0
    const n=5; var i, j, s, p: integer; a: array [1 ... n, 1 ... n] of integer; b, c: array [1 ... n] of integer; begin for i:=1 to n do for j:=1 to n do a[i, j]:=Random (100) ; { вывод на экран } for i:=1 to n do begin for j:=1 to n do write (a[i, j]:4) ; writeln; end; { цикл по массиву } for j:=1 to n do {цикл по колонке } begin s:=0; p:=1; for i:=1 to n do {цикл по строке} if (a[i, j] mod 2 = 0) then p:=p*a[i, j] else s:=s+a[i, j]; if (p>1) then c[j]:=p else c[j]:=0; if (s>0) then b[j]:=s else b[j]:=0; end; writeln ('массив для четных элементов') ; for i:=1 to n do write (c[i]:10) ; writeln; writeln ('массив для нечетных элементов') ; for i:=1 to n do write (b[i]:4) ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Заполнить двумерный массив с помощью датчика случ. чисел. Сформировать одномерный массив, закинуть произведение четных элементов по каждому ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Visual basic 1. Сформировать одномерный массив из восьми вещественных значений. 2. Сформировать двумерный массив из А строк и В столбцов. 3. Составить программу для определения максимального и минимального элементов двумерного массива. 4.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Заполнить одномерный массив B (5) с помощью датчика случайных чисел на интервале (-20; 20). На экран вывести в строку. На следующей строке указать сумму всех положительных элементов. 2.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и полученную сумму. 2. Дан массив В (n). Определите произведение элементов, кратных 3.
Ответы (1)
Дан двумерный массив Х из вещественных элементов размерностью n 1. В одномерный массив переписать отрицательные элементы двумерного массива, расположенные ниже главной диагонали 2.
Ответы (1)