Задать вопрос
13 июля, 11:39

Дан двумерный массив Х из вещественных элементов размерностью n

1. В одномерный массив переписать отрицательные элементы двумерного массива, расположенные ниже главной диагонали

2. Перенести в начало одномерного массива первый элемент, значение которого больше разности максимального и минимального элементов.

Для отладки программы элементы массива сформировать с помощью генератора случайных чисел

+2
Ответы (1)
  1. 13 июля, 15:02
    0
    {uses Crt; }

    {Для древних сред Паскаль, работающих в DOS-режиме, снять комментарии

    в операторах uses, ClrScr, ReadKey }

    const

    n = 9;

    var

    x: array[1 ... n, 1 ... n] of real;

    y: array[1 ... n * (n-1) div 2] of real;

    i, j, k: integer;

    max, min, d: real;

    begin

    Randomize;

    {ClrScr; }

    Writeln ('Исходный массив') ;

    for i : = 1 to n do

    begin

    for j : = 1 to n do

    begin

    x[i, j] : = 100*Random - 50;

    Write (x[i, j]:4:0)

    end;

    Writeln

    end;

    { задание 1 }

    k:=0;

    for i:=2 to n do

    for j:=1 to i-1 do

    if x[i, j]<0 then begin Inc (k) ; y[k]:=x[i, j] end;

    Writeln ('Сформированный одномерный массив') ;

    for i:=1 to k do Write (y[i]:4:0) ;

    Writeln;

    { задание 2 }

    max:=y[1]; min:=max;

    for i:=2 to k do

    if y[i]>max then max:=y[i]

    else

    if y[i]
    d:=max-min;

    i:=1;

    while (abs (y[i]) <=d) and (i<=k) do Inc (i) ;

    if i<=k then

    begin d:=y[1]; y[1]:=y[i]; y[i]:=d end;

    Writeln ('Результирующий одномерный массив') ;

    for i:=1 to k do Write (y[i]:4:0) ;

    Writeln;

    {ReadKey}

    end.

    Тестовое решение:

    Исходный массив

    37 - 45 - 17 - 26 - 6 - 22 - 1 - 33 - 3

    -27 33 - 15 - 14 33 37 28 - 12 - 36

    1 14 48 - 2 - 43 - 1 17 34 - 7

    -11 45 - 5 - 16 32 - 8 32 - 1 - 40

    18 43 - 13 - 28 30 45 44 - 38 - 28

    38 0 10 48 28 - 43 - 12 - 29 - 44

    2 - 11 48 33 7 10 35 - 40 - 28

    -48 39 - 49 42 5 - 16 26 - 40 - 5

    27 - 21 34 - 46 4 45 - 22 29 - 16

    Сформированный одномерный массив

    -27 - 11 - 5 - 13 - 28 0 - 11 - 48 - 49 - 16 - 21 - 46 - 22

    Результирующий одномерный массив

    -49 - 11 - 5 - 13 - 28 0 - 11 - 48 - 27 - 16 - 21 - 46 - 22
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан двумерный массив Х из вещественных элементов размерностью n 1. В одномерный массив переписать отрицательные элементы двумерного ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Visual basic 1. Сформировать одномерный массив из восьми вещественных значений. 2. Сформировать двумерный массив из А строк и В столбцов. 3. Составить программу для определения максимального и минимального элементов двумерного массива. 4.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
Сформировать двумерный массив А размером 5*7 с помощью генератора случайных чисел и вывести элементы массива на экран. Найти суммы положительных элементов каждой строки матрицы и записать их в одномерный массив В. Вывести элементы массива В на экран.
Ответы (1)