Задать вопрос
20 декабря, 08:31

Составить программу решения ах2+вх+с=0, а, в не равно нулю. Проверить случай, когда дискриминант болmше нуля меньше нуля и равен нулю.

+1
Ответы (1)
  1. 20 декабря, 12:19
    0
    program ii;

    var A, B, C, D: real;

    begin

    writeln ('Введите коэффициенты А, В, С') ;

    readln (A, B, C) ;

    if A=0 then

    writeln ('Уравнение не квадратное')

    else

    begin

    D : = B*B - 4*A*C;

    A : = 2*A;

    if D<0 then

    writeln ('Действительных корней нет')

    else

    if D=0 then

    writeln ('Корни равны: X1 = X2 = ', - B/A)

    else

    begin

    D : = sqrt (D) ;

    writeln ('X1 = ', (-B+D) / A) ; writeln ('X2 = ', (-B-D) / A) ;

    end; end; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу решения ах2+вх+с=0, а, в не равно нулю. Проверить случай, когда дискриминант болmше нуля меньше нуля и равен нулю. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу для решения уравнения AX2 + BX+C=0. (Дописать до конца) 2) Написать программу для решения неравенства Bx+C
Ответы (1)
1) Дано целое число N. Написать программу, заменяющую его 1, если число меньше нуля, и увеличивающую его на 6, если число больше или равно нулю. 2) Даны два числа a и b. Написать программу, которая выводит номер большего из них
Ответы (1)
Дано уравнение: xt1-yt2-zt3=0 Условие: x, y, z - вводит пользователь, причем x, y, z больше 0 (нуля) ; t1, t2, t3 должны быть больше 0 (нуля). Программа на Паскале решения данного уравнения. Всю голову уже сломали ... Есть умные решения.
Ответы (1)
Ввести с клавиатуры число. вывести на экран знак числа (+1 если больше нуля, - 1 если меньше нуля, 0 если равно нулю)
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)