Задать вопрос
5 февраля, 01:11

Дано m чисел найти цифры которые есть в записи каждого из m чисел (pascal ABC)

+2
Ответы (1)
  1. 5 февраля, 02:40
    0
    Var

    i, j, m, n: integer;

    a, b: array[0 ... 9] of boolean;

    begin

    for i : = 0 to 9 do a[i] : = true;

    write ('Введите количество чисел: ') ;

    read (m) ;

    write ('Введите числа: ') ;

    for i : = 1 to m do

    begin

    for j : = 0 to 9 do b[j] : = false;

    read (n) ;

    if n = 0 then a[0] : = true;

    while n 0 do

    begin

    b[n mod 10] : = true;

    n : = n div 10;

    end;

    for j : = 0 to 9 do a[j] : = a[j] and b[j];

    end;

    for i : = 0 to 9 do if a[i] then write (i, ' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано m чисел найти цифры которые есть в записи каждого из m чисел (pascal ABC) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc 2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)