Задать вопрос
6 января, 18:01

Данные о температуре воздуха за декаду хранятся в массиве. Определить, сколько раз температура была выше средней за эту декаду.

+2
Ответы (1)
  1. 6 января, 19:26
    0
    var

    a: array[1 ... 10] of integer;

    i, sum, count: integer;

    average: real;

    begin

    sum : = 0;

    writeln ('Данные о температуре: ') ;

    for i : = 1 to 10 do

    begin

    a[i] : = random (61) - 30;

    sum : = sum + a[i];

    write (a[i], ' ') ;

    end;

    writeln;

    average : = sum / 10;

    for i : = 1 to 10 do

    if a[i] > average then inc (count) ;

    writeln (count, ' раз (a) ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Данные о температуре воздуха за декаду хранятся в массиве. Определить, сколько раз температура была выше средней за эту декаду. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задачи по теме массив 1. В массиве хранятся сведения об оценках 25 учеников по химии. Определить количество неуспевающих по химии учеников. 2. В мвссиве хранятся сведения об общей стоимости товаров, проданных фирмой за каждый день марта.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
2. В массиве Z[1 ... N] определить сумму нечетных чисел от последнего нулевого значения до Z[N] и среднее арифметическое четных чисел, находящихся в массиве до последнего нуля. Если нулей в массиве нет, то рассортировать все числа по убыванию.
Ответы (1)
Дан массив, состоящий из целых чисел. Напишите программу, которая определяет, есть ли в массиве пара соседних элементов с одинаковыми знаками. Входные данные Сначала задано число N - количество элементов в массиве (1N10000).
Ответы (1)
Где хранятся программы управляющие работой процессора? Где хранятся данные в то время, когда процессор с ними работает?
Ответы (1)