Задать вопрос
6 января, 16:10

Найти все нечётные делители заданного числа.

+3
Ответы (1)
  1. 6 января, 17:17
    0
    Program even_factors;

    var

    i, n: integer;

    begin

    write ('Число: ') ;

    readln (n) ;

    i : = 1;

    while (i * i) < = n do

    begin

    if (n mod i = 0) and (i mod 2 = 1) then

    begin

    write (i, ' ') ;

    if (n div i) mod 2 = 1 then

    write (n div i, ' ') ;

    end;

    i : = i + 1;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти все нечётные делители заданного числа. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Сформировать текст заданной длины, состоящий из 2 символов А и В. 2. Найдите количество символов заданного числа 25 3. Написать программу обращения заданного слова (вывести символы строки в обратном порядке). (слово привет) 4.
Ответы (1)
1. Составьте алгоритм вычисления суммы квадратов цифр, заданного трехзначного числа. 2. Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа. 3.
Ответы (1)
Два множества: первое все простые делители некоторого целого числа N и второе все простые делители того же числа. Вывести на экран делители которые не являются простыми. (Паскаль)
Ответы (1)
Дан целочисленный массив размера N. Увеличить все нечетные числа содержащиеся в массиве на исходное значение последнего нечётного числа. Если нечётные числа в массиве отсутствуют, то оставить массив без изменений
Ответы (1)
Дан массив целых чисел, состоящий из 25 элементов. заполните его с клавиатуры. Найти: сумму элементов имеющих нечётные индексы; подсчитать количество элементов массива, значения которых больше заданного числа А и кратны 5
Ответы (1)